飞扬围棋论坛

 找回密码
 注册
搜索
查看: 2702|回复: 14

新手小白求助,linux系统,整合包如何设置katago,提示“加载引擎失败,可能引擎执...

[复制链接]
发表于 2021-11-29 20:05 | 显示全部楼层 |阅读模式
新手求助
回复

使用道具 举报

 楼主| 发表于 2021-11-30 16:53 | 显示全部楼层
求大神不吝赐教,谢谢
回复 支持 反对

使用道具 举报

发表于 2021-11-30 23:04 | 显示全部楼层
不清楚你的整合包指的是什么,看提示应该是权重文件参数设置有问题。如果单纯下载katago的github上的linux编译文件,最简单的设置是将权重文件名修改为default_model.bin.gz,然后运行./katago gtp
回复 支持 反对

使用道具 举报

 楼主| 发表于 2021-12-1 09:15 | 显示全部楼层
谢谢大神的指导,我下的是lizzieyzy整合包,专门供Linux系统用的,但是不带引擎、权重和配置文件,然后专门下载了Linux版本的katago,按照windows的引擎设置方法配置了引擎。目前lizzie界面可以打开,但是引擎加载失败,提示“error13,权限不够”。推测是katago需要安装?编译?还是其他设置调整,对Linux零了解,不要见笑。
回复 支持 反对

使用道具 举报

发表于 2021-12-1 10:05 | 显示全部楼层
既然对linux不怎么了解,为啥不用windows版的呢?
回复 支持 反对

使用道具 举报

发表于 2021-12-1 12:32 来自手机 | 显示全部楼层
sudo chmod 777 katago
回复 支持 反对

使用道具 举报

发表于 2021-12-1 12:32 来自手机 | 显示全部楼层
sudo chmod 777 katago
回复 支持 反对

使用道具 举报

 楼主| 发表于 2021-12-1 15:38 | 显示全部楼层
谢谢大神的指点,请问“sudo chmod 777 katago”在哪里使用?如何使用?

回复 支持 反对

使用道具 举报

发表于 2021-12-1 16:57 | 显示全部楼层
回答的有些唐突,这是Ubuntu终端下运行。我看你在Linux下以为你有一定基础。我原先在Ubuntu下运行Lizzie、katago都正常。
回复 支持 反对

使用道具 举报

发表于 2021-12-1 19:34 | 显示全部楼层
一般以为Linux下运行速度快一点,其实,不是编程人员,win哪里不好
回复 支持 反对

使用道具 举报

发表于 2021-12-1 20:42 | 显示全部楼层
chmod 777的意思就是把权限改为谁都可以执行。

还是用windows玩吧。
回复 支持 反对

使用道具 举报

发表于 2021-12-1 20:53 来自手机 | 显示全部楼层
本帖最后由 512song 于 2021-12-1 21:13 编辑

Linux下可不是快一点的问题.linux没有那么难,GPU云服务器还是linux为主流,尝试新事物总不是坏事。
回复 支持 反对

使用道具 举报

 楼主| 发表于 2021-12-2 08:27 | 显示全部楼层
谢谢您的答复,对linux是被迫使用,0基础。个人分析,在开源网站下载的katago(linux版本),直接解压后,不能被lizzie调用。请高手解答下载下来的katago程序,需要什么操作?或者提供高手制作包含引擎的成品整合包下载渠道,谢谢!
回复 支持 反对

使用道具 举报

 楼主| 发表于 2021-12-2 08:38 | 显示全部楼层
本帖最后由 rjycom 于 2021-12-2 10:27 编辑

加载错误已经解决了,现在是“引擎异常关闭,多条命令用英文分号隔开”
回复 支持 反对

使用道具 举报

 楼主| 发表于 2021-12-2 16:46 | 显示全部楼层
感谢3#5#11#的答复,加载错误已经解决了,现在卡在参数设置,提示“引擎异常关闭,多条命令用英文分号隔开”
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|Archiver|手机版|飞扬围棋网 ( 苏ICP备11029047号-1 )

GMT+8, 2022-5-23 00:44 , Processed in 0.155577 second(s), 19 queries .

since 2003飞扬围棋论坛 Licensed

© 2001-2013 Comsenz Inc.

快速回复 返回顶部 返回列表